Nogard

Join 0 other players on nogard.us

Nogard

Join 0 other players on nogard.us

Now Supporting Minecraft 1.12 Through 1.16

Nogard now supports any version of Minecraft between 1.12 and the latest, 1.16. All blocks and game mechanics still follow the way 1.12 worked, since this is the base version.

However, this is soon to change. The Nogard team has been working on a new update for a long while now, and Nogard players can expect to see this update come sometime in July. This will be our biggest update yet, with the base version being updated to 1.16 and lots of new changes that we hope you enjoy. Stay on the look out for more information coming soon.

Thanks, and hope to see you on the server sometime soon!

 

Edit: We are now also supporting Minecraft version 1.16.1.




Owner of Nogard. Links: Website | Contact

Jun 24, 2020 at 4:32AM
Edited Jun 25, 2020 at 3:17AM